Network Rendering Quick List:

Before you Render:
1) Run the Maya Render Diagnostics.
2) Delete your empty/unused nodes.
3) Do an IPR or Single Frame Render.
4) Make sure all of your textures/source images/ and
reference files are located in your project folder.

Launching the Render

1) Create a folder with your name on the renderfarm share.

2) Copy your project folder from your workstation to the
folder you created on the server.

3) Open the scene file across the network and reset your
project folder to the new location.

4) Check your render globals to insure you are using the
correct settings.

5) Use Qube to launch your render.

Verification and Cleanup
1) Check your render’s status with the commander station.
2) Remove your images and project when finished.

Troubleshooting common problems.
1) Read this entire document, including the FAQ
2) Email Steve at sdickinson@sva.edu for help.




Rendering Solutions at SVA:

Students at SVA have a choice of various rendering solutions to meet their needs. It
is important to choose the right renderer for the right job. Most 3d animation jobs can be
done using the dedicated Renderfarm (Qube) exclusively. In addition, Qube can be used
to process jobs from other software packages, such as After Effects or Fusion. If you or
your students wish to use the Renderfarm for compositing, please contact the systems
administrator for direct instructions.

In addition, certain larger jobs can be cleared to use not just the dedicated
Renderfarm, but the classroom computers as well. Programs such as Smedge are
available to the students who need extremely large amounts of processing horsepower.
This program harnesses the power of the classroom computers, but these will require
permission from the Systems Administrator.

The Dedicated Render farm (Qube)

As of fall 2007, the Renderfarm will consist of 80 CPUs dedicated exclusively to
rendering Maya, After Effects, and Fusion. The Renderfarm is rather picky, and students
must obey its conventions or it will not function correctly. Both students and faculty
should not operate from false assumptions about how the farm works. Failure to use the
farm properly can result in locking up or corruption of the renderfarm’s worker nodes.
Abuse of the farm will result in removal of rendering privileges.

Dispelling illusions about what a Renderfarm does (and does not) do.

At SVA, the Qube Renderfarm is a group of computers that work together to render a
heavy 3d or 2d project. The farm will not render individual frames faster; only take the
work required and spread it out across multiple machines. A Renderfarm can greatly
reduce the amount of time required to render a scene, but it is NOT a miracle cure for
rendering problems. If a scene cannot be rendered on one machine, than it cannot be
rendered on a Renderfarm. Technical errors must be corrected before scene files are
placed on the Renderfarm. To do this, follow these instructions carefully:

FOR MAYA 8.5:
Before you Render:

1) Run the Maya Render Diagnostics. To do this, launch your scene in Maya and go
to the render module. There choose ‘Render -> Run Render Diagnostics’. This will give
you a series of messages that will display possible problems that can occur you’re your
scene is uploaded to the farm. Many of these errors are benign, and will not affect your
final frames. Others however can cause serious problems and even crash the farm. You
should examine these errors are solve as many as possible before submitting your work.

2) Delete your empty/unused nodes. To do this, go to ‘Window -> Rendering Editors
-> Hypershade.” Then do ‘Edit -> Delete Unused Nodes.” This will remove many of




these ‘trash’ nodes and reduce errors, increase performance, and halt potential render
‘glitches.’

3) Do an IPR or Single Frame Render. This serves two purposes. First, it will insure
your textures/lights/character are all loaded correctly. There is no point in sending a 5
hour render to the farm if you forget to link your textures properly. Second, it tells you
how long a machine will take to render one frame, and that will help you forecast how
long your entire project will take.

4) Make sure all of your textures/source images/ and reference files are located in
your project folder. (Normally C:\Douments and Settings\yourname\My
Documents\Maya\Projects...\) Do not reference any files from external harddrives, USB
devices, or other PCs.

Launching the Render

1) Create a folder with your name on the renderfarm share on the network. The
Renderfarm uses a high-speed RAID array located on the network at \\Cylon\Framestore\.
Create a folder in this space with your login name as the name of the folder. Make
certain you create the folder from a PC, and that you are logged in as yourself when you
do.

2) Copy your project folder from your workstation to the folder you created on the
server. Make sure Maya is closed and the scene files you wish to render have been
saved. By default, the project file is located at C:\Douments and Settings\yourname\My
Documents\Maya\Projects\ The folder is often several Gigs of data, and may take several
minutes to transfer. Copy the project to the folder created in step #1 above. Make sure
you copy the folder, not move it.

3) Open the scene file across the network and reset your project folder. Open your
project folder on the network and launch your scene file FROM THE NETWORK.
(Example: \\Cyclon\Framestore\sdickinson\Benchmark\scenes\Benchmark1.mb) Once
open, reset your project settings to the new location by clicking File -> Project -> Set,
and then browsing to the appropriate folder. Once your project is set, run the render
diagnostics again. This will check your scene for broken links to your textures, as well as
any reference files that might be missing.

4) Check your render globals to insure you are using the correct settings. The render
globals are found at Window -> Rendering Editors -> Render Settings. These settings
are used by the Renderfarm when it starts your render. There are many critical functions
here, the most important of which are:

Image File Output: Make certain your naming convention uses the # before the ext

option. This will allow programs such as fCheck and Photoshop to correctly open
your image sequences.




Start Frame and End Frame: Make sure they are set to the frames you wish to start
and end your rendering on.

Renderable Cameras: This will be the view that will be rendered. Insure it is the
one you want.

Image Size: Most likely this will be HD 720 or HD 1024 depending upon which
resolution your final project will take.

5) Use Qube to launch your Render. Once all of your settings are confirmed, you can
launch the Qube render from the farm by clicking Qube! -> Submit Render. This will
give you’re the Qube! Submission settings, which should mirror your render settings, and
only require minor adjustment. Set these fields appropriately:

Job Name: Put the name of your scene and shot number here. This will help you
identify your job after it’s been sent to the farm.

CPUs: This is the number of CPUs assigned to your job. The more CPUs assigned
to your job, the more frames that can be worked on at the same time. MORE IS
NOT ALWAYS FASTER. See the FAQ for details.

Image Directory: This will be the network location where your finished frames will
be deposited. Anything placed in this box must be reachable by all of the
Renderfarm nodes.

Cameras: Allows you to choose which camera will be the primary render source.
For best practices, there should only be one camera in each shot.

Layers: This field should be set to whichever layer you wish to render. If there are
multiple layers, choose All Renderable.

Click Submit to send the job to the farm. Your job will be assigned an ID number
that will allow you to track its progress from the command station.

Verification and Cleanup

1) Check your render’s status from the command station. A single computer has been
set up in room 304 to allow Renderfarm users to observe the status of their work on the
farm. The machine is called 304-QubeWatcher, and it is located on the right (south) side
of the room, next to the door to the room where the Renderfarm is physically located.
Anyone can log onto this workstation and see the status of the jobs on the farm by
clicking on the desktop icon called ‘Qube.’

ID: This is the ID number that was assigned to your job when you submitted your
work.

% Done: Shows the percentage of frames that have finished rendering and have been
deposited in the images folder you specified. Frames that are still in progress or
have not started yet are not counted in this total.

State: Shows if the job is pending (hasn’t started yet), working, completed, or failed.

Name: This is the name you assigned to your project.




Properties: This is a short, list of technical information about your job. It provides a
‘at a glance’ overview of the work you submitted, as well as any glaring problems
that might affect its status.

Stderr: This is a more detailed list of highly technical information about your job. It
includes the step-by-step processing of your frame as reported out of Maya. This
section is very useful for troubleshooting glitches or artifacting due to internal
Maya rendering problems.

Graph: This section has a easy-to-read graphical display of each of your jobs and
how long it took each frame to render. It is very handy for showing the
relationships between scene activity and rendering time.

2) Remove your images and project when finished. Copy your renders back to your
local workstation from the network renderfarm drive (
\\Cyclon\Framestore\vourname\projectname\images\ ) and check them for errors using
fCheck, Photoshop, or After Effects. Once you are certain that there are no problems,
delete the frames off the network, and make sure you back up your work.




Frequently Asked Questions:

How long will it take to render my work?
Estimating how long a render will take requires a simple formula. The formula is:

Rendertime = (F *T)/ C

“F” is the total number of frames in your job.
“T” is the amount of time a single computer takes to render one frame.
“C” 1s the total number of CPUs you’ve dedicated to the job.

The total number of frames, multiplied by the amount of time it takes to render one
frame, will give you the amount of time it would take one computer to render your job.
Divide this number by the number of CPUs dedicated to your job, and you have an
estimated amount of time required to render your work.

Is it done yet?
You can tell if your work is finished by launching Qube on the command station in

304 and checking the status of your job. Completed job will have a status of “Complete”.

Where are my frames?

By default, finished frames are placed on the network in your project folder. Files
rendered with Maya Software or Maya Hardware renderers are placed in the
\WCyclon\Renderfarm\yourname\projectname\images folder. Frames rendered with
MentalRay will be in the
\WCyclon\Renderfarm\yourname\projectname\renderData\mentalRay folder.

The job is finished, my frames look fine, but Qube says it failed.

Qube is designed to work with a number of different types of software, and is very
sensitive to Maya warnings about possible problems. If Maya reports a possible problem,
but finishes the frame without trouble, Qube will interpret this as a failure and mark the
job with a “failed” status. If you encounter this situation, review the earlier section
entitled Before you Render and make certain you have followed those instructions. If
you continue receiving failures, contact the Systems Administrator.

My work looks ‘funny’

If your scene uses dynamics, you may have problems with the Renderfarm. Certain
effects like hair and particle systems are generated locally on each machine you use to
render. This can give your system an inconsistent look. You can solve this problem by
“baking your cache”, or pre-rendering your instances. Instructions on how to bake your
cache are available in the Maya Help menus, or contact the Systems Administrator.




My Textures wont load

Check the path names to your textures folder. Make sure you placed your textures in
proper location. (Usually \\Cyclon\Renderfarm\yourname\projectname\textures ) Also,
check to make sure your project is set to the network share, and not the local hard drive.

The Wrong Camera is rendering

Go to your render settings and check the Renderable Cameras setting. Often students
will leave this set to perspective instead of the camera they wish to render from. If the
render settings are correct, check the Oube Submission screen to make certain that Qube
is not overriding the render settings with its own camera.

My layers are missing

Check your Layer Manager to insure that all of the layers you want to render have the
‘visible’ and ‘renderable’ flags set. Then check the Qube Submission settings under
Layers and insure that any layers you want to work on are selected correctly.




